Yes, I need to fill this out. At the moment (Nov 2015) I’m converting pages over from my old WordPress installation, which got crusty over time. I’m really enjoying the simple feel of Jekyll at the moment.